TH NextGen - Main differences in TrendHub Next Generation

Welcome to TrendHub Next Generation!

Over time, we received a lot of feedback from our customers on how we could improve the user experience within TrendHub. Additionally, we wanted to renew our technology, which would allow us to introduce new functionality faster. Both angles led to the creation of TrendHub Next Generation.

With TrendHub Next Generation we implemented more than 600 feature ideas we received from our customers. Seeing the many improvements, it is almost impossible to list all of them. We are convinced you will discover small improvements on a daily basis!

There are a number of changes, though, that need emphasis, since they will impact your routine when working with TrendHub: 

  • Saving a view is now done through the action button on the view bar (top right of the screen) and no longer through the view menu in the left menu bar.  
  • The Recommender Engine has been replaced by the Diagnose menu and is now available in the left menu bar.  
  • Influence Factors has been rebranded to Prediction Tags and is now part of the Tag Builder  
  • The What's new Inbox and the monitor configuration menu has been replaced by one monitoring tab, which can be found in the top bar, next to the Work Organizer.  
  • The new monitoring screen will only show enabled monitors. 
  • The workflow to set up searches has been simplified, allowing easy replication of the analysis on new time periods or similar assets. Multiple calculations have been introduced which are saved as part of the search 
  • The creation of a search-based filter is no longer performed in the search menu. Instead, these filters are created in the filter menu where a search can be selected.  
  • The blue help and heart button have been replaced by a help center in the top menu bar, next to the new monitoring tab. The help center includes all known resources, with the addition of a brand new getting-started guide which allows you to access in-app tours at their own pace. 

The next sections of this document will provide a detailed description of all these changes. Next to the current document, there are multiple additional resources at your disposal to help with the transition:  

  • Our new 20-minute eLearning course to get introduced to TrendMiner Next Generation (ideal for your transitioning to TrendHub Next generation) 
  • Our brand new TrendHub Basic eLearning for a more comprehensive introduction (ideal for new and recent TrendMiner users) 
  • Our new getting-started guide where you can follow in-app tours on request (described below) 

Central role for views 

A lot of attention was given to our trend viewer capabilities when redesigning TrendHub. The most notable change is the central role for views. At any given time, a reference will be shown to the current active view, and actions on views (like saving, exporting data) are now available from the action button in the view bar. The view menu does still exist, but it is merely an entry point to the Work Organizer.  

View.png

When saving a view, you will notice that there is no longer an option to specify which time frame needs to be saved (the current one or a relative one). The type of view and how this will influence the timeframe when opening the view, is now purely defined by the state of the lock and the state of the live mode button. 
The following table explains how the state of the live mode and the lock determines the type of the view. 

View type 

Live mode state 

Lock state 

Historical view 

Disabled 

No influence 

Live mode fixed time span 

Enabled 

Closed 

Live mode fixed start  

Enabled 

Open 

The picture below explains conceptually how the view type will affect the visualized time frame when opening the view. t0 represents the moment the view was saved, while t1 represents the moment the saved view is opened. 

View4.png

Other notable changes regarding views and trend viewing in general include the following: 

  • The visualization mode is stored in a saved view and this mode will also be used when adding the view as a trend tile in DashHub. 
  • Every visualization mode has its own chart configuration settings, which allows you to, e.g., visualize or hide context items, show gridlines, show histograms, … 
  • Stacked mode is now the default visualization mode in TrendHub. 
  • Reading values on specific time stamps is made easier by displaying the values on the vertical ruler and by the addition of gridlines. 

ruler_gridlines.png

  • When grouping tags, with autoscaling enabled, the scale will be set based on the overall maximum and minimum value of all tags of that group. This avoids confusion when navigating to other periods. 

TagDetails.1.9.png

  • Additional navigation actions have been added to the focus chart like: 
    • Zooming on mouse scroll action. 
    • Click and drag possibility on the time axis. Depending on the lock state, you can browse through time while keeping the time span fixed (closed lock) or increase the time span (open lock). 
    • Undo time navigation button next to the lock. 
  • Descriptive statistics for the base period (Statistics) and all other layers (Compare layers) are easily accessible and can be displayed together with the time series data. 

Statistics.1.0.png

  • The double slider, which was used to select the time period of the context chart, has been replaced by easy preconfigured time periods. Selecting a custom period or range is possible with the custom selector.  
  • Clicking twice on the left menu buttons will close the side panel, maximising the focus chart. In addition, the side panel can also be enlarged to easily read long tag names and descriptions. 

FocusChart.1.3.0.png

Diagnose to replace Recommender Engine 

The Recommender Engine has been replaced by the Diagnose menu to facilitate global Root Cause Analysis. It has also moved position. You can now find the well-known lightbulb icon in the left-side menu, between all other functionality, and no longer in the top menu bar.  
Additional general improvements include the following: 

  • A clear distinction is made between the cross-correlation analysis and the fingerprint deviation analysis for a better discovery of both functionalities. 
  • All settings can be adjusted before the analysis is started and a persisted result list is shown. This allows you to visually validate candidates without losing the complete analysis. The overall flow is very similar to the search workflow. 

Diagnose_cross.png

As will be discussed in the following section, the Influence Factors functionality has been rebranded and moved to the Tag Builder menu, making Diagnose the go to menu for Root Cause Analysis. The following improvements have therefor been added to the cross-correlation analysis, which were a limiting factor in the old Recommender Engine:   

  • An upstream shift detection can be specified up to 24 hours, instead of the default, fixed 1 hour.  
  • The minimum and maximum time shift is shown in case multiple layers are used for the analysis. 

screenshot2.png

Prediction Tags to replace Influence Factors 

Prediction Tag builder is replacing our influence factors functionality to facilitate soft-sensor creation. The predictive tags allow you to create a multi-variable, linear model to predict the value of interest from any other available data.

The creation of these tags is made more user-friendly by introducing a completely new workflow which guides you to the final model in different steps. When initiating the workflow, a dedicated chart is shown on which the model will be visualized.  

screenshot3.png Next to the change in workflow, the following improvements have been implemented: 

  • Listed candidates are no longer returned in bins but in one list to have a better overview of all your results without opening/closing all those bins. The candidates are sorted based on their score, and only the top 300 results are shown. 
  • Tag/Attribute descriptions are now included for the listed candidates to better understand which candidate is shown. 
  • When saving the final result, the model, including the complete workflow settings, is saved as a new Tag Builder type, i.e., prediction tags. This allows you to easily retrain the model at a later stage if it is no longer accurate.  

screenshot4.png

  • Results are persisted when switching menus and selected candidates are persisted when changing the search scope. This enables more flexibility to evaluate different selection of tags and time shifts to be evaluated during the setup of your model. 
    For example, you can now first perform a local analysis, add a couple of candidates to the model and then continue with a global analysis, to further increase the accuracy of the model.  

Unified Monitoring Center 

The TrendHub Inbox and monitor configuration menu are no longer present in the left menu. Both have been replaced by the monitoring center, which can now be found in the top menu bar, next to the Work Organizer.  

 

Monitoring_topbar.png

 
The monitoring tab is accessible in all hubs. When opening the monitor tab, you will be presented a full screen table containing all enabled monitors. This is a big change when compared to the older versions of TrendMiner. Every search or fingerprint can still be used as a monitor, but you will need to manually add them to the overview list by enabling the monitor. By doing so, we get rid of the messy monitor list containing all saved searches and fingerprints.  

Other advantages of the unified monitoring center include the following:  

  • Accessible in all hubs.  
  • A nicely organized table overview of only the enabled monitors, which can be sorted on Name, Type and timestamp of the last result.  
  • A persisted list of the 50 most recent monitor results for each monitor. Results will always be shown in this table, even if no actions are enabled. Recent results no longer disappear like they did in the What's new Inbox.  
  • Clear indication of unseen results with labels and blue rows.  
  • Clickthrough available to the original search or fingerprint, in case the conditions of the underlying item need to be modified.  

Group_23.png

Streamlined search experience 

Both the workflow of performing searches and the user experience when working with the search results have been improved.  
The workflow of the searches has been unified, to provide the same experience, whether you start a new search or start from a saved search. There are now only 2 main screens: 

  • The search setup screen to specify the search conditions. 
  • The search detail screen providing a summarized overview of the search conditions. 

The biggest change is the edit flow. In the old TrendHub versions it was impossible to quickly change the condition of a saved search without completely overwriting it. This has now been changed. 
Similar to the views, "unsaved changes" will be indicated when editing the conditions. Afterwards, you can decide to save the search as a new search, to overwrite the current search, or to discard the changes. This allows you to easily iterate on saved searches and to apply the same analysis on similar assets.  

Saving_search.png

Multiple calculations  

Being able to perform and export multiple calculations on top of search results has probably been the most requested feature. With the introduction of TrendHub Next Generation, this feature is now available and can be found as an action on the search detail pane.

Up to 30 calculations can be added at once. In the search result list, one specific calculation can be selected which will be visualized on top of the results and will be used when sorting on calculations.  
As a bonus, the calculation definitions will be saved as part of the search, once again simplifying the reproduction of your analysis. Once calculation definitions are available, the calculations will be executed when performing the search.  

calc_search.png

calc_search2.png

Result list improvements 

Working with the search results is now much easier and there are multiple improvements included in this release.

You can now switch between showing the results in bins (default option) or to show them as a flat list. Click on the flattening button to display the results in a scrollable list. When scrolling down, you will notice that the complete side panel is used to visualize results. When needed, you can easily jump back to the top of the list by clicking on the blue arrow displayed on the result list.  

 
flattening.png

backup.png

Sorting of the search result list has been slightly modified. Switching the sorting mode of the bins (date, duration, calculation or score), can be done in the search results menu.  
The direction of the selected sorting mode can now easily be changed with the dedicated sorting button 

sorting.png

sorting_options.png

Adding the results as layers is simpler and clearer than before.  Setting a layer as base or adding an additional layer are now two clearly distinct options, avoiding mis clicks completely.  
Additionally added layers will be displayed with the layer icon and indicated by a blue color. The base layer will be indicated with a “B” (base).  
For similarity searches, the query period is explicitly added as a search result and indicated with the “Q” (query) icon. This enables the inclusion of the query period in filters, exports and calculations.  layering.png

Creation of search-based filters 

In older TrendMiner versions, search-based filters needed to be created when saving the search itself. We noticed that this flow wasn't intuitive. New users naturally looked for the create option inside the Filter menu itself.

This is exactly what we introduced in TrendHub Next Generation. To create a search-based filter, you still first need to have a saved search. Once a search is available, you can create a filter by clicking the blue plus button in the header of the filter menu. 

filter.1.4.png

Once the add search-based filter button is clicked, a right-side panel is shown where you can define your search-based filter and save it right away. Filters are now also considered work items and will therefore appear in the Work Organizer, inheriting work item capabilities like copying and sharing. 

This also means that the Filter menu will no longer show all existing filters by default. Filters will need to be added to the current session and are considered part of the view. When saving a view, all added filters, including their state, will be stored inside the view definition.  

filter.1.5.png

Help menu with getting-started guide. 

To accommodate the change in user experience, we have launched an improved in-app learning & support experience. All resources can now be found in the top bar, as well as the well-known options to reach out to the TrendMiner team.

The help center will take you to the TrendHub Next Generation documentation, while clicking E-Learning courses will direct you to our online learning platform.  
A brand new getting-started guide is now included which allows you to access in-app tours at your own pace. 

Helpcenter.png

Important: Data gathering needs to be enabled to be able to use the getting-started guide. 

 

 

Enjoying TrendMiner? Share your experience to help the community and receive $25.
Rate TrendMiner